My code works, I don’t know why.

國王的耳朵是驢耳朵

Ubuntu 16.04更新到Ubuntu 18.04後Octopress 環境變動

| Comments

本來想要寫一些東西,結果發現rake在Ubuntu 無法執行,只好先處理了。

主要的問題是更新後Ruby版本從16.04使用的2.3升級成2.5了。以下是我紀錄過的測試指令,必須承認這是網路上的東西剪貼,我不想知道後面的原理,後果自行負責。寫這篇文章另一個目的是確定上傳到網路上後可以正常發佈才證明真的解決問題了。

預安裝套件

1
sudo apt -y gcc libcurl4-openssl-dev libxml2-dev

Ruby 相關更新,完全不知道做啥

1
2
3
sudo gem install bundler
bundle install
sudo gem install rake

更新Octopress Gemfile

由於更新後rake版本也從10.5.0變成12.3.1,所以一跑rake就會出現版本不合的錯誤,因此我把Gemfile rake的版本檢查改成12,diff 檔案如下

1
2
3
4
5
6
7
8
9
10
11
12
13
diff --git a/Gemfile b/Gemfile
index 153dd3d..9f5048b 100644
--- a/Gemfile
+++ b/Gemfile
@@ -1,7 +1,7 @@
 source "https://rubygems.org"

 group :development do
-  gem 'rake', '~> 10.0'
+  gem 'rake', '~> 12.0'
   gem 'jekyll', '~> 2.0'
   gem 'octopress-hooks', '~> 2.2'
   gem 'octopress-date-format', '~> 2.0'

參考資料

Comments